Loading

./autogen output

  1.  ./autogen.sh
  2. aclocal: installing 'build/autotools/glib-gettext.m4' from '/usr/share/aclocal/glib-gettext.m4'
  3. aclocal: installing 'build/autotools/gsettings.m4' from '/usr/share/aclocal/gsettings.m4'
  4. aclocal: installing 'build/autotools/gtk-doc.m4' from '/usr/share/aclocal/gtk-doc.m4'
  5. aclocal: installing 'build/autotools/intltool.m4' from '/usr/share/aclocal/intltool.m4'
  6. aclocal: installing 'build/autotools/libtool.m4' from '/usr/share/aclocal/libtool.m4'
  7. aclocal: installing 'build/autotools/ltoptions.m4' from '/usr/share/aclocal/ltoptions.m4'
  8. aclocal: installing 'build/autotools/ltsugar.m4' from '/usr/share/aclocal/ltsugar.m4'
  9. aclocal: installing 'build/autotools/ltversion.m4' from '/usr/share/aclocal/ltversion.m4'
  10. aclocal: installing 'build/autotools/lt~obsolete.m4' from '/usr/share/aclocal/lt~obsolete.m4'
  11. aclocal: installing 'build/autotools/nls.m4' from '/usr/share/aclocal/nls.m4'
  12. Copying file po/Makefile.in.in
  13.  
  14. Please add the files
  15.   codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
  16.   progtest.m4
  17. from the /usr/share/aclocal directory to your autoconf macro directory
  18. or directly to your aclocal.m4 file.
  19. You will also need config.guess and config.sub, which you can get from
  20. ftp://ftp.gnu.org/pub/gnu/config/.
  21.  
  22. libtoolize: putting auxiliary files in AC_CONFIG_AUX_DIR, `build'.
  23. libtoolize: copying file `build/ltmain.sh'
  24. libtoolize: putting macros in AC_CONFIG_MACRO_DIR, `build/autotools'.
  25. libtoolize: copying file `build/autotools/libtool.m4'
  26. libtoolize: copying file `build/autotools/ltoptions.m4'
  27. libtoolize: copying file `build/autotools/ltsugar.m4'
  28. libtoolize: copying file `build/autotools/ltversion.m4'
  29. libtoolize: copying file `build/autotools/lt~obsolete.m4'
  30. libtoolize: Consider adding `-I build/autotools' to ACLOCAL_AMFLAGS in Makefile.am.
  31. configure.ac:54: installing 'build/compile'
  32. configure.ac:27: installing 'build/config.guess'
  33. configure.ac:27: installing 'build/config.sub'
  34. configure.ac:47: installing 'build/install-sh'
  35. configure.ac:47: installing 'build/missing'
  36. contrib/egg/Makefile.am: installing 'build/depcomp'
  37. configure.ac: installing 'build/ylwrap'
  38. libide/Makefile.am:650: installing 'build/py-compile'
  39. parallel-tests: installing 'build/test-driver'
  40. checking build system type... x86_64-unknown-linux-gnu
  41. checking host system type... x86_64-unknown-linux-gnu
  42. checking whether make supports nested variables... yes
  43. checking for a BSD-compatible install... /usr/bin/install -c
  44. checking whether build environment is sane... yes
  45. checking for a thread-safe mkdir -p... /bin/mkdir -p
  46. checking for gawk... gawk
  47. checking whether make sets $(MAKE)... yes
  48. checking whether UID '1000' is supported by ustar format... yes
  49. checking whether GID '1000' is supported by ustar format... yes
  50. checking how to create a ustar tar archive... gnutar
  51. checking whether to enable maintainer-specific portions of Makefiles... yes
  52. checking whether NLS is requested... yes
  53. checking for style of include used by make... GNU
  54. checking for gcc... gcc
  55. checking whether the C compiler works... yes
  56. checking for C compiler default output file name... a.out
  57. checking for suffix of executables...
  58. checking whether we are cross compiling... no
  59. checking for suffix of object files... o
  60. checking whether we are using the GNU C compiler... yes
  61. checking whether gcc accepts -g... yes
  62. checking for gcc option to accept ISO C89... none needed
  63. checking whether gcc understands -c and -o together... yes
  64. checking dependency style of gcc... gcc3
  65. checking for intltool >= 0.50.1... 0.50.2 found
  66. checking for intltool-update... /usr/bin/intltool-update
  67. checking for intltool-merge... /usr/bin/intltool-merge
  68. checking for intltool-extract... /usr/bin/intltool-extract
  69. checking for xgettext... /usr/bin/xgettext
  70. checking for msgmerge... /usr/bin/msgmerge
  71. checking for msgfmt... /usr/bin/msgfmt
  72. checking for gmsgfmt... /usr/bin/msgfmt
  73. checking for perl... /usr/bin/perl
  74. checking for perl >= 5.8.1... 5.18.2
  75. checking for XML::Parser... ok
  76. checking how to run the C preprocessor... gcc -E
  77. checking for grep that handles long lines and -e... /bin/grep
  78. checking for egrep... /bin/grep -E
  79. checking for ANSI C header files... yes
  80. checking for sys/types.h... yes
  81. checking for sys/stat.h... yes
  82. checking for stdlib.h... yes
  83. checking for string.h... yes
  84. checking for memory.h... yes
  85. checking for strings.h... yes
  86. checking for inttypes.h... yes
  87. checking for stdint.h... yes
  88. checking for unistd.h... yes
  89. checking locale.h usability... yes
  90. checking locale.h presence... yes
  91. checking for locale.h... yes
  92. checking for LC_MESSAGES... yes
  93. checking libintl.h usability... yes
  94. checking libintl.h presence... yes
  95. checking for libintl.h... yes
  96. checking for ngettext in libc... yes
  97. checking for dgettext in libc... yes
  98. checking for bind_textdomain_codeset... yes
  99. checking for msgfmt... (cached) /usr/bin/msgfmt
  100. checking for dcgettext... yes
  101. checking if msgfmt accepts -c... yes
  102. checking for gmsgfmt... (cached) /usr/bin/msgfmt
  103. checking for xgettext... (cached) /usr/bin/xgettext
  104. checking whether ln -s works... yes
  105. checking for itstool... itstool
  106. checking for xmllint... xmllint
  107. checking for gcc... (cached) gcc
  108. checking whether we are using the GNU C compiler... (cached) yes
  109. checking whether gcc accepts -g... (cached) yes
  110. checking for gcc option to accept ISO C89... (cached) none needed
  111. checking whether gcc understands -c and -o together... (cached) yes
  112. checking dependency style of gcc... (cached) gcc3
  113. checking for g++... g++
  114. checking whether we are using the GNU C++ compiler... yes
  115. checking whether g++ accepts -g... yes
  116. checking dependency style of g++... gcc3
  117. checking for valac... /usr/bin/valac
  118. checking whether /usr/bin/valac is at least version 0.30.0.55... no
  119. configure: WARNING: no proper vala compiler found
  120. configure: WARNING: you will not be able to compile vala source files
  121. checking for flex... flex
  122. checking lex output file root... lex.yy
  123. checking lex library... -lfl
  124. checking whether yytext is a pointer... yes
  125. checking for bison... bison -y
  126. checking for glib-genmarshal... /usr/bin/glib-genmarshal
  127. checking for glib-mkenums... /usr/bin/glib-mkenums
  128. checking for glib-compile-resources... /usr/bin/glib-compile-resources
  129. checking for ANSI C header files... (cached) yes
  130. checking for pkg-config... /usr/bin/pkg-config
  131. checking pkg-config is at least version 0.22... yes
  132. checking for gobject-introspection... no
  133. checking for pkg-config... (cached) /usr/bin/pkg-config
  134. checking pkg-config is at least version 0.9.0... yes
  135. checking for vapigen... no
  136. checking for pkg-config... (cached) /usr/bin/pkg-config
  137. checking pkg-config is at least version 0.16... yes
  138. checking for appstream-util... no
  139. checking pcre.h usability... yes
  140. checking pcre.h presence... yes
  141. checking for pcre.h... yes
  142. checking whether C compiler accepts -std=gnu11... yes
  143. checking whether g++ supports C++11 features by default... no
  144. checking whether g++ supports C++11 features with -std=c++11... yes
  145. checking for gmake... make
  146. checking for sched_getcpu... yes
  147. checking for EGG... no
  148. configure: error: Package requirements (glib-2.0 >= 2.47.4
  149.                              gmodule-2.0 >= 2.47.4
  150.                              gtk+-3.0 >= 3.19.7) were not met:
  151.  
  152. Requested 'glib-2.0 >= 2.47.4' but version of GLib is 2.40.0
  153. Requested 'gmodule-2.0 >= 2.47.4' but version of GModule is 2.40.0
  154. Requested 'gtk+-3.0 >= 3.19.7' but version of GTK+ is 3.10.8
  155.  
  156. Consider adjusting the PKG_CONFIG_PATH environment variable if you
  157. installed software in a non-standard prefix.
  158.  
  159. Alternatively, you may set the environment variables EGG_CFLAGS
  160. and EGG_LIBS to avoid the need to call pkg-config.
  161. See the pkg-config man page for more details.